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Thank you for purchasing the IQC2110 
Capture and Playback system  

The X-COM IQC2110 makes it possible for users of Tektronix, Agilent and Rohde and Schwarz Signal 
Analyzers to increase their signal storage to hours or days. This capability gives users an 
unprecedented ability to analyze complex, wideband, long duration, and intermittent wave forms. 
The IQC2110 can continuously record and play back the full 16 bit I and Q data stream from the 
RSA6000A signal analyzer with bandwidths up to 110 MHz, and up to 40 MHz with the Rohde and 
Schwarz FSV or Agilent X-Series Signal Analyzers. Signals are stored in a non-proprietary format to 
allow analysis by a wide range of digital signal processing tools. When combined with an X-COM 
SigAnalyst workstation and X-/haΩǎ Spectro-X software, users have a very powerful turn-key digital 
signal processing capability. By adding an X-COM CPG (Continuous Playback Generator) and a Vector 
Signal Generator, users can play back recorded signals with exceptional fidelity. 

 

Compatible Signal Analyzers 

Vendor Compatible Signal Analyzer Supported Spans 

Tektronix All RSA5000A Series with Option 55 

All RSA6000A Series with Option 05 

10 kHz to 85 MHz, discrete**  

10 kHz to 110 MHz, discrete**  

Agilent PXA - No Options 

PXA Option B25 

PXA Option B40 or Option B1X  

MXA or EXA with Option DP2  

MXA or EXA with Option B25 + Option DP2 

MXA or EXA Option B40 + Option MPB 

Up to 10 MHz 

Up to 25 MHz 

Up to 40 MHz 

Up to 10 MHz 

Up to 25 MHz 

Up to 40 MHz 

Rohde and Schwarz FSV with Option B17 and EX-IQ Box Rev 2.0 Up to 40 MHz 

**See Table Tektronix RSA6000A Discrete Capture Spans 
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IQC System Wiring Diagram, using the Tektronix RSA6000A or 5000A Series 

 

Cable # Cable Type 

1 4 x LVDS Cables  

2 
2 x Datapack Cables ς 

external MiniSAS 

3 
н Ȅ .b/ /ŀōƭŜǎΣ рлҠ 
RG58, Equal Length 

4 3 x Ethernet Cable 

5 2 x eSATA Cables 
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IQC System Wiring Diagram, using the Agilent X-Series 

 

 

      

 

Cable # Cable Type 

1 1 x Agilent LVDS Cable  

2 
2 x Datapack Cables ς 

external MiniSAS 

3 2 x LVDS Cables 

4 
н Ȅ .b/ /ŀōƭŜǎΣ рлҠ 
RG58, Equal Length 

5 3 x Ethernet Cable 

6 2 x eSATA Cables 
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IQC System Wiring Diagram, using the Rohde and Schwarz FSV 

 

 

Cable # Cable Type 

1 1 x EX-IQ LVDS Cable  

2 1 x USB Cable 

3 2 x LVDS Cables 

4 
2 x Datapack Cables ς 

external MiniSAS 

5 
н Ȅ .b/ /ŀōƭŜǎΣ рлҠ 
RG58, Equal Length 

6 3 x Ethernet Cable 

7 2 x eSATA Cables 
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Setting up the X-COM 

IQC2110 System 

NOTE: The Datapack and eSATA archive are not 
hot-swappable ς they cannot be connected or disconnected while the power is on.  All other 
connections can. 

Turning on and Connecting the IQC System 

1. Connect the power cables 
Connect power cables to all devices: Signal Analyzer, IQC, CPG, VSG, Datapack, 

and PC. 
 

2. Connect the Datapack Cables from the IQC to the Datapack 
 Connect the IQC Datapack cables (external MiniSAS cables) from the back of the 
IQC chassis to the corresponding Datapack slots marked I and Q ς either the top or 
bottom slot (see Figure 1). 

 
3. Power on the Datapack 

Toggle ON the power switch on the back of the Datapack. Please allow the 
Datapack to initialize for at least 30 seconds prior to continuing. Note that the Datapack 
is not hot-swappable, therefore it should not be powered off and the external MiniSAS 
cables should not be disconnected unless the IQC Chassis is turned off. 
 

Figure 1: 

Connecting the Datapack 
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4. Connect the eSATA Archive to the IQC (Optional) 
If the eSATA offloading option has been purchased for the IQC, connect power to 

the eSATA archive, and turn it on.  Next, connect the eSATA cables to the IQC.  eSATA 
hot-swapping is not supported, so follow the same protocol connecting eSATA drives as 
for connecting a Datapack. 

 
5. Power on the IQC Chassis 

Toggle ON the power switch located in the bottom-right corner on the back of 
the IQC. After turning on the power switch, the IQC takes approximately 8 seconds to 
initialize ς wait before pressing the LED power button located in the top-right corner on 
the front of the unit. The IQC Chassis will take approximately 2 minutes to boot, during 
which time the green power LED on the front of the unit will flash. The system will be 
ready to capture once this green LED has stopped flashing and is solidly lit.  (Likewise, 
the LED will flash until solidly lit when switching between capture and playback modes.) 

 
6. Connect the network  

Connect Ethernet cables from the control PCΩǎ Ethernet port, the port marked 
LAN on the IQC, and the LAN port of the signal analyzer to an Ethernet switch. 

Connecting for Capture 

7. Tektronix RSA: Connect the LVDS cables from the IQC to the RSA 
 On the back panel of the RSA, locate the Digital IQ Out (LVDS) ports.  Connect 
the I and Q LVDS cables from the Digital IQ Out (LVDS) ports to the corresponding I and 
Q ports marked Capture on the back of the IQC Chassis (see Figure 2).  Turn on the RSA. 

Figure 2: 

LVDS Ports, IQC Chassis Back ς for Tektronix RSA Capture 
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Agilent X-Series: Connect the Agilent LVDS cable from the IQC to the X-Series SA 

Connect the thinner end of the Agilent LVDS cable to the Capture I port.  
Connect the wider end to the X-Series Digital OUT port. 
 
Rohde and Schwarz FSV: 

a) Mate the RSX adapter box with the EX-IQ Z-Dok connector.   
b) Connect the wide LVDS cables from the RSX I and Q to the IQC Capture I and Q 

(see Figure 1).   
c) Connect the smaller LVDS cable from the EX-IQ IN port to the FSV Digital OUT 

port. 
d) Connect a USB cable from the EX-IQ to the FSV. 

 

Connecting for Playback 

8. Connect the LVDS cables from the IQC to the CPG 
Connect the I and Q cables from the back the CPG to the corresponding I and Q 

ports marked Playback on the back of the IQC Chassis (see Figure 2).  Turn on the CPG. 
 

9. Connect the BNC Cables from the CPG to the VSG 
 Connect the corresponding I and Q BNC cables from the front of the CPG to the I 
and Q baseband inputs of the VSG. 
 

10. Connect the Reference Oscillator OUT from the VSG to the IQC Clock IN 
(Recommended) 
 Use a 50-Ohm BNC cable to connect the reference oscillator OUT from the VSG 
to the clock IN on the IQC.  An internal reference is recommended when playing back, 
but is not necessary for capture. 
 

11. Connect an IRIG B Device for Time-Tagging Markers (Optional) 
The following IRIG B type devices may be used for time-referencing markers 

during capture: 
 

¶ IRIG B120, for CF = IEEE-1344 

¶ IRIG B121, for CF = IEEE-1344 

¶ IRIG B122 

¶ IRIG B123 
 
Connect the IRIG output of the device to the IRIG IN on the IQC2110 using a рл ʍ 

BNC cable (see Figure 3).  The IQC will automatically synchronize with the IRIG device 
when it is receiving a locked signal from the satellites.  The time format for IRIG B types 
is Coordinated Universal Time (UTC). 

 



 7 

 

 

12. Marking Data During Capture (Optional) 
You can use the Trigger inputs on the IQC to mark data during the capture with a 

timestamp.  Markers are useful as reference points for playback, analysis and partial 
downloading of a captured file.  To use this feature, connect an external trigger from an 
oscilloscope, signal analyzer, or any other device that provides a rising edge TTL level 
trigger, to the IQC TRIG 1 IN using a BNC cable (see Figure 3).  You may also connect a 
second triggering device to TRIG 2 IN.  Set your device(s) to output triggers on desired 
events and the data will be marked at those samples (see section Inserting Markers 
During Capture). 

Figure 3: 

Connections for marking 

data, IQC Chassis Back 
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Setting up the IQC Control 

Software and Workstation for 

the First Time 

1. Install the IQC Control Software (One-time) 
 Install the IQC Control Software on a PC or laptop that will be used to control the 
IQC.  Windows XP, Vista (32 and 64 bit) and 7 (32 and 64 bit) are supported. 
 
The installation of IQC Control software will add exceptions for 3 ports in Windows 
Firewall automatically.  If you wish to manually configure these ports in Windows 
Firewall: 

a. Go to Start > Control Panel > Windows Firewall > Exceptions > Add Port.  
b. Add port number 5843 in the port number field, select UDP, and click OK.   
c. Open ports 5844 and 5845 in the same manner, this time choosing TCP as the 

communication type. 
Add exceptions for these ports in any antivirus software that may be running on the 
control computer. 

 
2. Customizing the IQC network setup (Optional ς One-time) 

 The Lv/Ωǎ ŘŜŦŀǳƭǘ Lt ŀŘŘǊŜǎǎ ƛǎ мфнΦмсуΦнΦнллΦ If the IQC does not need to be 
changed from the default IP address, skip to Step 7 (e.g.: configured for operation 
within a LAN of a different subnet). 

 
The IQC can be configured to have a static IP address and used on a LAN with other 
networked devices. The user should determine the following IQC configuration 
information ahead of time: 
- IP address the IQC should be set to 
- Subnet mask 
- Gateway IP address 
- DNS IP address 
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3. Configure the PC to communicate 
with the IQC via DHCP 

Set up the control PC to obtain 
an IP address and DNS server address 
automatically. The following 
procedure demonstrates how to do 
this on a Windows XP PC: 

 
- Go to Start > Control Panel > 

Network Connections. 
- Right-click on the adapter icon which 

the IQC is connected to. Select 
Properties. 
 
 
 
 

- Highlight Internet Protocol and 
click on the Properties button. 
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- Select both options Obtain an IP address 
automatically and Obtain DNS server 
address automatically. Click OK, and then 
OK on the Connection Properties box. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Connect the PC to the IQC Auxiliary port 

Move the Ethernet cable from the port labeled LAN on the IQC to the port 
labeled AUX. Make sure that there is a direct connection from the AUX port to the 
control PC, not through any routers or switches. 

 
5. Launch the IQC Control Software 

The IQC Control Software 
will attempt to connect to the IQC, 
but fail once it is launched.  Please 
click Cancel when the dialog box 
appears stating that IQC Control 
failed to connect.  

 
Next, select Edit > Network > 
Connect to the IQC Auxiliary 
Network Port within IQC Control.  
A return announcing a successful 
connection should appear.  If not, 
verify that there is a direct 
connection from the control PC to 
the AUX port and that DHCP is 
enabled on the control PC, and 
then restart IQC Control. 
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6. Configuring the IQC network setup 

 Within IQC Control, go to Settings> Network> IQC WAN Network Settings.  
Enter the custom network configuration. Click on Apply, then click Done. 
 

 
 

Note: When connecting directly to the IQC, the Gateway and DNS IP addresses can be set to .1 
ƻŦ ǘƘŜ ǎŀƳŜ ǎǳōƴŜǘ ŀǎ ǘƘŜ Lv/Ωǎ Lt ŀŘŘǊŜǎǎΦ 
 

7. Set the IP address of the control PC 
 The IP address of the control t/Ωǎ 9ǘƘŜǊƴŜǘ ŎƻƴƴŜŎǘƛƻƴ ǎƛƳǇƭȅ ƴŜŜŘǎ ǘƻ ōŜ ǎŜǘ ǘƻ 
a static IP address in ǎŀƳŜ ǎǳōƴŜǘ ŀǎ ǘƘŜ Lv/Ωǎ Lt ŀŘŘǊŜǎǎΦ The default IP address of the 
IQC is 192.168.2.200, with a subnet mask of 255.255.255.0. In order to communicate 
with this IP address, the IP address of the control PC can be set to 192.168.2.X, where X 
= 2 to 254, but not 200 (the IQC and control PC should not be set to the same IP 
address). This can be done by following the procedure in step 3, by choosing Use the 
following IP address instead of choosing Obtain an IP address automatically. 
 

8. Connect the PC to the IQC LAN port 
Move the Ethernet cable back from the port labeled AUX to the port labeled LAN 

on the IQC. The connection may now be made through a switching device, and does not 
have to be directly connected. 

 
9. Click on the Connect button in IQC Control Software 

The IQC Control Software should now be able to connect to the IQC. Once 
connected, a list of the XIQ files on the Datapack should be listed. 
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Setting up the Tektronix Real-

Time Signal Analyzer 

Refer to the Tektronix RSA Operating Manual for more detailed 
instructions.  The following steps are intended to provide a quick setup.  A setup file is included with the 
RSA to expedite setup time.  To access it, go to File>RecallΧ in the RSA application and navigate to 
Desktop>RSA-Settings.  Open the file IQC_FRS_CH2.Setup.  Review the following section if you would 
like to get more familiar with manually setting up the RSA. 

 
1. Power On 

Press the power button on the bottom left of the unit.  Wait for the display to 
initialize.   
 

2. Set the IP address of the RSA to 192.168.2.32. (One-time) 
Optionally, you can change the IP address of the RSA in Remote Device Control. 

3. Set the capture mode in IQC Control to Tektronix. 
Go to  Edit > Select Capture Mode > Tektronix. 

4. Alignment 
Alignment should be 

performed after a 20-minute warm-
up.  The alignment mode should not 
be set to automatic, else the I/Q 
streaming data is interrupted by an 
automatic calibration.   

Go to Tools>Alignments.  
Select the Run alignments only when 
ά!ƭƛƎƴ bƻǿέ button is pressed option. Select Align Now to perform alignment. 

 

5. Turn on I/Q outputs 

In order to stream data to the I/Q external connectors, the I/Q output option 
must be turned on.  Select Setup > Configure IN/OUT.  Then go to the Other Outputs 
tab and select On under the IQ Output field. 
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6. Adjust the Center Frequency 
Select the Center Frequency adjustment box just below the main toolbar and 

enter the frequency value corresponding to the signal of interest.   
 

 
 
 

7. Adjust the Span 
Select the Span adjustment box and enter the bandwidth frequency that is wide 

enough to view the entire signal of interest.  This is done by going to Setup > Settings.  
From there adjusting the value in the Span text box under the Freq & Span tab. 

 

 
 
 

8. Adjust the Reference Level  
Select the reference level adjustment box just below the main toolbar and set it 

to the desired level to view the signal.  Signal strength should not go beyond the range 
of the RSA, as this can damage internal components. 
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9. Attenuation 
In many cases, the attenuation can be set automatically by the instrument.  For 

optimum recording, the attenuation should be set manually to a level that does not 
overdrive the A/D circuitry.  This is done by going to Setup > Amplitude.  From here you 
can adjust the Internal Attenuator manually or automatically under the Internal Settings 
tab. 

 

 
 
 

10. Adjusting the Resolution Bandwidth 
Go to Setup > Settings.  Select the BW tab and adjust the resolution bandwidth 

in the RBW textbox. 
 

 
 
 

11. Setting the Reference Oscillator (Recommended ς For Use when Playing Back into the 
RSA from the VSG) 

Go to Setup > Configure In/Out.  Select the Frequency Reference tab.  Select the 
External radio button. 
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Setting up the Agilent X-

Series Signal Analyzer 

Refer to the X-Series Operating Manual for more detailed 
instructions on signal analyzer operation.  The following represents the minimum steps required to 
perform capture with the IQC.  Button presses and SCPI commands are provided for each step.  The 
following notation is used: 

b_ = Button on front panel 

SCPI command (optionally, for remote control) 

 

1. Power On 
Press the power button on the 

bottom-left of the signal analyzer.  Wait for 
the display to initialize, and the unit to 
calibrate. 

 
 

2. Set the IP address of the SA to 192.168.2.220. (One-time) 
a. Once the SA is up, log off user Instrument. 
b. Log on as administrator (no caps), password agilent4u. 
c. Change the IP address like you would in XP. 

 
Optionally, you can change the IP address of the SA in Remote Device Control. 

3. Set the capture mode in IQC Control to Agilent. 
Go to  Edit > Select Capture Mode > Agilent. 

 
4. Adjust the Center Frequency to a signal of 

interest. 
 

b_FREQ XYHz 

FREQ:CENT XYHz 

 

 

 

 

 

Power on default view 

Step 4: Adjust the center frequency 
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5. Adjust the Capture Span to include the 
signal.  A max span of 40 MHz is supported. 

 

b_SPAN XYHz 

WAV:DIF:BAND XYHz 

 

 

 

 

 

 

 
6. Click the Capture button in IQC Control. The 

SA will configure to capture mode. 

 

 

 

 

 

7. Adjust Amplitude, Attenuation, and IF Gain in IQC Control.  Update the SA. 
 

To modify the settings on the SA, click Update IQC in capture control to update the capture file 

settings on the IQC.  Alternatively, change the settings in capture control and click Update SA. 

 

Step 5: Adjusting the capture span 

Capture mode of the X-Series SA 
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Setting up the Rohde and 

Schwarz FSV Signal Analyzer 

Refer to the FSV Operating Manual for more detailed 
instructions on FSV operation.  The following represents the 
minimum steps required to perform capture with the IQC.  Button presses and SCPI commands are 
provided for each step.  The following notation is used: 
 

b_ = Button on front panel, s_ = Softkey on display 

SCPI command (optionally, for remote control) 

 

1. Power On 
Press the power button on the 

bottom-left of the FSV.  Wait for the display 
to initialize, and the unit to calibrate. 

 
 

 
2. Set the IP address of the FSV to 192.168.2.110. (One-time) 

Optionally, you can change the IP address of the FSV in Remote Device Control. 

3. Set the capture mode in IQC Control to Rohde and Schwarz. 
Go to  Edit > Select Capture Mode > Rohde & Schwarz. 

4. Adjust the Center Frequency to a signal of 
interest. 
 

b_FREQ XYHz 

SENS:FREQ:CENT XYHz 

 

 

 

 

 

 

 

 

 

Power on default view 

Step 4: Adjust the center frequency 
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5. Adjust the Capture Span to include the 
signal.  A max span of 40 MHz is supported. 

 

b_SPAN XYHz 

FREQ:SPAN XYHz 

 

 

 

 

 

 

 

6. Adjust Pre-Amp, RF Attenuation to suit.   
 

b_AMPL > s_Pre-Amp ON  
INP:GAIN:STAT ON 

 
b_AMPL > s_RF Attenuation 0 
INP:ATT X 

 

 

 

7. Click the Capture button in IQC Control. The FSV will configure to capture mode. 

 

 

 

 

 

 

 

To further adjust settings on the FSV, press s_Local to enable the touchscreen and modify 
settings, then click Update IQC in capture control to update the capture file settings on the IQC.  
Alternatively, change the settings in capture control and click Update FSV. 

IQ Analyzer mode (digital streaming capture 
mode) 

While configuring, the FSV display will blank. 

Step 5: Adjusting the capture span 

Step 6: Setting the attenuation 
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Setting up the R&S SMBV 

Vector Signal Generator 

Refer to the VSG Operating Manual for more detailed 
instructions.  The following represents the minimum steps required to perform RF playback. 

A setup file is included with the VSG to help get you started.  To access it, press the Setup key on the 
VSG front panel and scroll down to {ŀǾŜκwŜŎŀƭƭΧ  under the System header.  (Using a USB mouse makes 
navigation much easier.)  Make sure that Recall appears in the drop-down menu, select the file 
SMBVSetup, and click on the Recall button at the bottom of the menu.  Review the following section if 
you would like to know how to manually set up the VSG. 

 

1. Power On 
Press the power button located on the 

bottom-left of the unit.  Wait for the display 
to initialize. 

 
2. Set the Unit to Import Analog Wideband I 

& Q Data 
Press the Menu button.  Click on I/Q 

Mod.  Scroll down to and select Analog 
Wideband I/Q In under the I/Q Mod In 
header. See Figure 4. 

 
3. Center Frequency 

Enter the center frequency which 
corresponds to the original RF frequency 
captured by the RSA. 

 
4. Level 

Set the desired output level by 
entering the appropriate dBm value. 

 
5. Modulation 

Press the Mod Off and RF Off buttons 
to initiate RF output.  The block diagram 
should look like Figure 5.  It is important to 
make sure that the last two blocks ς I/Q Mod 
and RF/A Mod ς are blue (activated), and 
that RF Off and Mod Off boxes do not appear at the top of the screen.  The first two blocks 
in the diagram correspond to internal generation of signals (and are not generally used for 
IQC playback); the last two correspond to input and modulation. 

Figure 4: Setting the SMBV to Import Analog 
Wideband I & Q Data 

Figure 5: SMBV Block Diagram Configuration for 
Playback 
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Setting up the Agilent PSG 

Vector Signal Generator  

Refer to the PSG Operating Manual for more detailed 
instructions.  The following represents the minimum steps required to perform RF playback. 

 

1. Power On 
Press the power button on the bottom-left of the unit.  Wait for the display to 

initialize. 
 

2. Configure the I/Q settings 
Press the I/Q button on the front panel of the PSG.  Using the buttons to the right of 

the LCD screen to select the proper options, set I/Q Mode ON, and I/Q Path to Normal 
(Mux Source).   

 
3. ALC 

Press the Amplitude button.  Turn ALC ON. 
 

4. Configure the Mux 
Press the Mux button on the front panel of the PSG.  Select IQ Source.  In the next 

submenu, select Ext 50 Ohm.  If you have the correct settings applied, your screen should 
now look like this: 

 
5. Center Frequency 

Press the 
Frequency button on the 
front panel of the PSG.  
Enter the center 
frequency which 
corresponds to the 
original RF frequency 
captured by the RSA. 

 
6. Level 

Press the 
Amplitude button on the front panel of the PSG.  Set the desired output level by entering 
the appropriate dBm value. 

 
7. Modulation 

Press the Mod On/Off and RF On/Off buttons to initiate RF output. 

PSG Block Diagram and Settings for I/Q Baseband In Playback 
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Using the IQC Control Software  

IQC Control is a remote control interface into the operations of the IQC 
System.  This interface controls capture, playback, and file management on the 
IQC System. 
When the IQC Control panel is opened, it connects to the IQC System automatically.  A dialog box will 
appear confirming a successful connection, and the Connect/Disconnect button will read Disconnect 

IQC File Listing 

Files stored on the Datapack are listed in the IQC Control panel.  The file listing includes the 

fileΩǎ ƴŀƳŜΣ size, modification date, and protection status.  The protection status helps prevent 

accidental deletion by disabling the Delete File button.  Each file captured through the IQC 

System contains an IQC file header.  The header is used to store information, such as a fileΩǎ 

span, frequency, markers, and protection status. If a file is uploaded that does not contain an 

XIQ header, protection and other automated features will not be available. 

 

IQC Control Panel 














